Why am I getting an unrouteable mail domain error?

The most likely cause for unrouteable email domain error is exceeding the hourly email sending limits (100/hour/domain) for all shared hosting accounts. If that's not the cause and you believe you are still within your limits, submit a ticket to our support team and a system admin will look into it for you.

Send email marketing using Buyhttp myMail service

  • 1 Users Found This Useful
Was this answer helpful?

Related Articles

What is my email login information?

You can access your email using IMAP or POP3 protocols. Your login is: [email protected]...

What type of e-mail accounts does BuyHTTP offer?

We offer POP3 and IMAP e-mail accounts.Host your educational website with Buyhttp

I can't seem to email from my site.

If you are having problems sending email from your site, this is an easy script to help you...

How do I configure Thunderbird?

Start your own  hosting business with Buyhttp reseller package